What's New in 3rdRail 1.1

By: Glenn Weyhausen

Abstract: What's New in 3rdRail 1.1

The latest release of 3rdRail includes significant enhancement in the following areas:

    Rails 2.0

Support for creating and working with projects based on Rails 2.0 (in addition to Rails 1.2). This support includes enhancements in the Wizards, Rails Explorer, Dependencies View, Project Commander, Code Completion, and Refactoring.

3rdRail includes a complete, turnkey Ruby on Rails runtime environment including databases, Ruby, Rails, the Gem manager and a number of special Gems and tools. Plus, you get a developer license for InterBase®, CodeGear’s database for embedded and enterprise applications.

    Fast Debugging

A new high-performance integrated debugger for fast, visual, debugging of Ruby and Rails projects, including support for Embedded Ruby (aka ERb, RHTML, HTML.ERB).

- Fully integrated with 3rdRail IDE

- Support for both Ruby and Rails

- Support for ERb debugging (Embedded Ruby, RHTML)

- Detailed formatters for Ruby and Rails specific data structures

Hide image
Click to see full-sized image

    RESTful Resources

New support for creating and working with RESTful Resources in both Rails 1.2 and 2.0 projects, including a "New Rails Resource" wizard.

Hide image
Click to see full-sized image

    Code Completion

Additional support for even more scenarios and patterns, including Sexy Migrations, Foxy Fixtures, the helper methods for Routes and Assertions, and more.

Hide image
Click to see full-sized image

    Ruby/Rails Runtime

Updated to include latest versions of Ruby, RubyGems, Rails, etc. Also, includes the latest versions of InterBase, MySQL, and SQLite.

    Rails Version Migration

Added support for detection and resolution of common issues when migrating an application from Rails 1.2 to 2.0. For instance, if your application connects to an Oracle database, 3rdRail will detect the dependency and offer a resolution of installing the "activerecord-oracle-adapter" gem, which isn't included in a default Rails 2.0 installation. Look for these messages and their associated resolution actions in the Problems View.

    Additional Supported Platforms

Added support for Mac OS®/X 10.5 (aka Leopard) and Ubuntu 7.10 – in addition to Microsoft Windows Vista and Windows XP.

Server Response from: ETNASC04