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Introduction
Borland® JBuilder® Enterprise is a comprehensive set of award-winning visual development tools
for creating enterprise-scale applications written entirely in the Java™ programming language for
the Java 2 platform.
JBuilder 8 Enterprise provides out-of-the-box integration with the market-leading J2EE™ platform
application servers like Borland® Enterprise Server 5.x, BEA WebLogic Server™ 5.1, 6.x, 7.0,
IBM® WebSphere® 3.5, 4.0, iPlanet™ 6.x, Sybase® Enterprise Application Server 4.1. Also JBuilder
8 has a plug-in to integrate with the Oracle 9i™ Application Server 9.0.3.
JBuilder 8 Enterprise ships with Tomcat 3.x and 4.x, and provides end-to-end integration with
Tomcat.
This paper provides an overview of creating, testing, and debugging Web applications using
Borland JBuilder 8 Enterprise and IBM WebSphere Application Server Advanced Edition 4.0.
The other platforms and software used to create the exercises are Optimizeit™ Suite 5.0, Windows
XP,™ and Microsoft® Internet Explorer 6.0.
Refer to the white paper “Borland JBuilder 8 Configuration with J2EE Application Servers” for
installation and configuration instructions for integrating JBuilder 8 Enterprise with WebSphere
Advanced Edition 4.0.
WebSphere runs on the IBM JDK® (Java Version J2RE 1.3.0 IBM Build cn130-20010601) and
JBuilder is capable of creating, deploying, testing, and optimizing Web applications hosted on the
IBM JDK.
Followings are the list of Web technologies that can be easily developed, debugged, and tested
using JBuilder 8 wizards. Web applications developed with any other technologies not mentioned
here can also be easily imported to JBuilder 8 and managed.
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Technology

Description

Servlets

A server-side Java application which can process requests from clients.

JavaServer
Pages™ (JSP™)

An extension of servlet technology. JavaServer Pages use custom tag
libraries and offer a simplified way to develop servlets.

InternetBeans
Express

A set of components and a tag library provided by Borland, used for
easier presentation and manipulation of data from a database.

Struts

An open source tag library provided by the Jakarta Project that is used
for building Web applications. Struts provides a flexible control layer
based on standard technologies like servlets, JSP, JavaBeans,®
ResourceBundles, and XML.

JavaServer Pages
Standard Tag
Library (JSTL)

A tag library provided by Sun that is part of the Java Web Services
Development Pack 1.0 (WSDP). It provides a set of tags that allow
developers to do common tasks in a standard way. The JSTL consists of
four areas, each with its own TLD (tag library descriptor) and
namespace.

Cocoon

A servlet-based, Java publishing framework for XML that is integrated
into JBuilder. Cocoon allows separation of content, style, and logic and
uses XSL transformation to merge them. It can also use logic sheets,
Extensible Server Pages (XSP), to deliver dynamic content embedded
with program logic written in Java.

Applets

A specialized kind of Java application that can be downloaded by a
client browser and run on the client’s machine.

Table 1: List of major Web technologies supported by JBuilder 8

Wor king with JSP ™
Create a project
Start JBuilder 8. Click File -> New -> Select Project tab from the Object Gallery. Click Project.
Click OK. In the Project Wizard—Step 1 of 3 specify a Directory Name and a Project Name.
Leave the Template as (Default Project). Click Finish.
For this exercise, the project directory is E:\DEMO\WebSphere\TestWebProjet and Project
Name is TestWebProject.
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Attach WebSphere® to current project
You can attach the WebSphere Application Server to the current project. From the JBuilder main
menu bar, click Project -> Project Properties. Click Server tab. Select WebSphere Application
Server Advanced Edition 4.0 from the combo box.
See Figure 1 for details.

Figure 1: Project Properties window allowing users to select application server of choice
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Note: The Services panel in the left-hand side show the services provided by the specific server selected
in the combo box (this case WebSphere Application Server AE 4.0). JBuilder is intuitive and automatically
discovers the services provided by a selected Web or application server. In this case, deployment, EJB,

™

and JSP/servlet are enabled because these services are available with WebSphere AE 4.0.
Note: You can click on each service from the Service panel and see what specific versions of different
technologies are supported by the chosen Web or application server. In the above figure, the JSP/servlet
service is clicked from the Service panel and JBuilder is showing the supported JSP and servlet versions
with WebSphere AE 4.0.

Note: JBuilder provides users the option of choosing one server for all services in the project or multiple
servers providing different servers. With Modular Services provided by different servers, users can
configure different services to be run by different servers. For example: users can select Tomcat for
®

JSP/servlet server, Borland Enterprise Server for EJB and another server for connector.

For our exercise, leave the default, which is Single server for all services in the project.
Click on Deployment from the Services panel. Note that by default, the Build target for deploying
to server is Make. If you prefer not to build the archives at the time of deployment, choose <None>
from the combo box. This will stop building the project during deployment and make the
deployment faster.
Click OK and JBuilder project TestWebProject is now configured for WebSphere Application
Server AE 4.0.

Attach the WebSphere® Application Server to all the projects
If you decide to use WebSphere AE 4.0 for all of your projects, you can set this as default. From
JBuilder menubar click Project -> Default Project Properties. Click Server tab. Select
WebSphere Application Server Advanced Edition 4.0 from the combo box and choose Single
server for all services in the project.
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Create a Web application
JBuilder 8 allows users to create a Web application that can host applets, Web Start launchers,
JSPs, servlets, and Apache™ Struts applications.
From the JBuilder main menubar, click File -> New -> Web tab in Object Gallery -> Web
Application. Click OK..
See Figure 2 for JBuilder 8 Object Gallery.

Figure 2: JBuilder 8 Object Gallery displaying the wizards to create Web applications
The Web Application Wizard pops up. Enter Name and Directory entries for the Web
application. For this exercise, the Web application name is TestWebApp and directory is
TestWebApp.
JBuilder provides an option to choose when the developers would like to build a WAR file. For this
exercise, leave the default which is When building project or Web app.
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From the JBuilder 8 project tree, expand the project, and expand the Web application
TestWebApp. Expand the deployment descriptors folder. Note that JBuilder has recognized that
the target server is WebSphere, so it automatically created the following deployment descriptors for
WebSphere.
ibm-web-bnd.xmi
ibm-web-ext.xmi
web.xmi

Click on web.xml. This opens the WebApp DD editor in the editor pane.
See Figure 3 for details.

Note: The Deployment Descriptor Editor tool in JBuilder provides a graphical user-friendly way to update
the web.xml, and it is a two-way tool. It automatically changes the XML source when the Deployment
Descriptor Editor is changed.
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Figure 3: JBuilder 8 Web Application Deployment DescriptorEditor

Create a JSP™
From the JBuilder main menubar, click File -> New -> Web tab in Object Gallery -> JavaServer
Page. Click OK..
In JSP Wizard—Step 1 of 6, enter a JSP name. For this exercise, the JSP name is TestJSP. Note
that the Web application TestWebApp is defaulted for hosting this JSP. You can check both the
checkboxes to generate a sample bean and an error page. Click Next.
In JSP Wizard—Step 2 of 6, you can select InternetBbeans technology, different tag libraries
from JSTL 1.0 and Struts. Leave the defaults and click Next.
In JSP Wizard—Step 3 of 6, enter the package name as com.borland.demo.web.
Click Next.
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At this point, you can click Finish. JBuilder automatically creates a runtime configuration named
TestJSP to run the created JSP.

Note: A runtime configuration is a configuration to run a runnable application in JBuilder 8. Runtime
configuration is essential when your project has multiple runnable files or applications, and you want to run
a specific application.

Create an EAR
WebSphere requires Web or EJB applications to be deployed as EAR. JBuilder has a wizard to
create EAR files easily.
Click File -> New -> Enterprise tab of Object Gallery -> click EAR -> click OK.
In the EAR Wizard, keep clicking Next until you get EAR Wizard–Step 5 of 6. Check the
checkbox under Include column. This includes the Web application TestWebApp in the EAR file.
Click Finish.

Make the project
To make the project, press Ctrl+Shift+F9 or click the Make icon from the JBuilder toolbar. As a
result of make, JBuilder automatically creates the WAR file TestWebApp.war and EAR file
TestWebProject.ear for the Web application.
See Figure 4 for details.
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Figure 4: JBuilder showing the generated sources, WAR file, and deployment descriptors for
WebSphere

Deploy and run the JSP™ in WebSphere®
Start WebSphere within JBuilder. To start WebSphere within JBuilder, click on the
Run Project icon from JBuilder toolbar and click TestJSP.
See Figure 5 for details.
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Figure 5: WebSphere AE 4.0 started within JBuilder
Now the EAR file can be deployed to WebSphere Application Server AE 4.0. To deploy the EAR
file, right-click TestWebProject.eargrp -> click Deploy Options for “TestWebProject.ear” ->
Deploy.
See Figure 6 for details.
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Figure 6: Deployment options to deploy archives to WebSphere
Another tab called WebSphere Application Server Advanced Edition 4.0 Enterprise Deployer
opens up in JBuilder message pane.
See Figure 7 for details.

Figure 7: WebSphere Application Server Advanced Edition 4.0 Enterprise Deployer tab showing
deployment status to WebSphere
To run the JSP, right-click TestJSP.jsp from JBuilder project tree, click Web run using
TestJSP.jsp
The AppBrowser runs the JSP and displays the message JBuilder Generated JSP.
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If you like to see the deployment status in WebSphere console, start the WebSphere console by
clicking Tools -> WebSphere 4.0 AE Administrator’s Console.
Expand Nodes -> <ServerName> -> Application Servers -> Installed Web Modules, and you
can find the Web application TestWebApp in the right-hand window. Also the console displays the
status of the Web application.
See Figure 8 for details.

Figure 8: WebSphere Advanced Administrative Console displaying the deployed Web application
TestWebApp

Note: If you don’t see WebSphere 4.0 AE Administrator’s Console under JBuilder 8 Tools menu, it is
because you haven’t selected this option during server configuration. Click Tools -> Configure Servers > Select WebSphere Application Server Advanced Edition 4.0 from left-hand panel of Configure
Servers window, click Custom tab from the right-hand panel, and make sure that checkbox against Add
an Administrator Console item to the Tools menu is checked.
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Remote deployment
This section explains how to deploy an archive to a remote WebSphere Application Server.

Note: The users need to have a local installation of the application server for the remote deployment
because JBuilder need to use the deployment utilities from the local application server.

For deploying to a remote WebSphere Application Server AE 4.0, from JBuilder main menubar
click Tools -> Enterprise Deployment. A window called WebSphere AE 4.0 Deploy Settings
pops up.
Notice that the EAR TestWebProject.ear is already identified in the Archive(s) textbox.
In the Options field, specify -nameServiceHost <host name> -nameServicePort <port
number>, where hostname and port number are the parameters of remote WebSphere Application
Server. Also ensure that the Primary node name and the Application server name match the
settings on the remote server.
See Figure 9 for details.
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Figure 9: JBuilder remote deployment utility tool, to deploy archives to remote WebSphere

Debug the JSP™
To debug the JSP, assign breakpoints in the source code wherever necessary. To assign a
breakpoint, simply open the source file and single-click on that line.
Lets assign a breakpoint at line 7 of TestJSP.jsp. The line description is as follows.
<jsp:useBean id="testJSPBeanId" scope="session"
class="com.borland.demo.web.TestJSPBean" />

Provide the debug options to WebSphere. Start the WebSphere Server and start the WebSphere
Advanced Administrative Console. In the console, expand Nodes -> expand <server_name> ->
expand Application Servers -> click Default Server. Click
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JVM Settings tab at the right-hand side, and click Advanced JVM Settings button. In the
command line argument text field of Advanced JVM Settings window, add the following line.
Then click OK.
-Xdebug -Xnoagent -Djava.compiler=NONE
-Xrunjdwp:transport=dt_socket,server=y,address=3999,suspend=n

See Figure 10 for WebSphere Console with Advanced JVM Settings.

Figure 10 : WebSphere Console: Advanced JVM setting for debugging applications in WebSphere
Application Server AE 4.0
If WebSphere is already running, stop the WebSphere Application Server. Press Shift+F9 or just
click the Debug Project icon. Click TestJSP to start WebSphere in debug mode within JBuilder.
Note that JBuilder debugger has stopped at the breakpoint in JSP.
See Figure 11 for details.

Note: When you click Debug Project, JBuilder starts WebSphere Application Server in debug mode. Now
users can do the debug operations from JBuilder, such as see the thread information, breakpoint
information, console output, step over, step into, step out, etc.
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Figure 11: WebSphere Application Server running in JBuilder in debug mode and debugger
stopped at JSP breakpoint

Wor king with ser vlets
Create a servlet
JBuilder provides an easy-to-use wizard to create servlets.
Lets create a servlet with the same project TestWebProject and same Web application
TestWebApp.
From the JBuilder main menubar, click File -> New -> Web tab of Object Gallery -> Servlet.
Click OK.
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In Servlet Wizard–Step 1 of 5, find package name com.borland.demo.web from the Package
combo box. Also enter the servlet name as TestServlet. Note that TestWebApp is automatically
selected as Web application. Click Next.
In Servlet Wizard–Step 2 of 5, enter the methods that you want to use in the servlet. You can also
generate an SHTML file with the servlet.

Note: For this exercise, make sure the checkboxes against methods doGet() and doPost() are checked.
Leave other defaults and click Next.

Leave the defaults in Servlet Wizard–Step 3 of 5 and Servlet Wizard–Step 4 of 5.
Servlet Wizard–Step 5 of 5 allows you to create a runtime configuration for the servlet. Click the
checkbox Create a Runtime Configuration and leave the default configuration name as
TestServlet. At this point, since TestJSP runtime configuration is also created, so you can select
TestJSP as the Base Configuration. Click Finish.
Make the project. To make the project, click Ctrl +F9 or just click the Make icon from the
JBuilder toolbar.

Deploy and run the servlet
Start WebSphere Application Server within JBuilder. To start WebSphere within JBuilder, click
Run Project icon from JBuilder toolbar and click TestServlet.

Note: If WebSphere is already running within JBuilder, there is no need to restart again.

Redeploy TestWebProject.ear to WebSphere. Right-click TestWebProject.eargrp -> click Deploy
Options for “TestWebProject.ear” -> click Redeploy.
At this point, you can just right click the servlet TestServlet.java from JBuilder project tree -> click
Web Run -> click Use “TestServlet.” This will run the servlet and display the servlet output in the

19

Web Development Using JBuilder® 8 and WebSphere® Application Server

JBuilder AppBrowser. The URL that gets executed is
http://localhost:9080/TestWebApp/testservlet. You can also run this URL in your favorite browser
to see the servlet output.
See Figure 12 for details.

Figure 12: WebSphere running within JBuilder and displaying the server output

Debug the servlet
To debug the servlet TestServlet.java, assign breakpoints in the source code wherever necessary.
To assign a breakpoint, simply open the source file and single-click the mouse on that line.
Lets assign a breakpoint at line 20 of TestServlet.java. The line description is as follows.
out.println("<p>The servlet has received a GET. This is the reply.</p>");
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Make sure that the debug options are provided in WebSphere Console JVM settings. Refer to the
section Debug the JSP to learn how to provide debug options to WebSphere.
If WebSphere is already running, stop the WebSphere Application Server. Press Shift+F9 or just
click the Debug Project icon. Click TestServlet to start WebSphere in debug mode within
JBuilder. Note that JBuilder debugger stopped at the breakpoint in servlet.

Note: JBuilder put a green arrow mark at the breakpoint indicating that the debugger has stopped at that
line. If there is an invalid breakpoint, JBuilder will put a cross mark against it.

See Figure 13 for details.

Figure 13: WebSphere has started in debug mode within JBuilder and is debugging a servlet
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Wor king with Str uts
The Struts open source framework is known as the Model 2, or Model-View Controller, approach
to software design. This framework evolved from the Model 1 design, JavaServer Pages
technology. This technology offered great advances from pure servlets, where presentation HTML
was coded with lengthy out.println statements in doGet() and doPut() methods. JSPs offered a way
to include HTML in Java code and Java code in HTML. However, these JSPs are hard to read and
hard to maintain. Both Web designers and developers are required to work in the same set of source
files.
The Struts framework, first developed in 2001, combines the best of servlets and JSPs. The
framework consists of a three-tiered design paradigm: the Controller, Model, and the View. Struts
provides its own Controller component and integrates with other technologies to provide the Model
and the View. Using the Struts framework is now the preferred way to create robust and long-lived
professional Web applications.
For learning more about Struts, please visit http://jakarta.apache.org/struts/index.html. If you have
installed JBuilder 8, you can also get information about Struts from JBuilder Help.

Create a Struts application
Struts is the next generation Web application development. But it is difficult to write. A Struts
application development cycle is probably twice or three times longer than the conventional Web
application development cycle.
But JBuilder makes the Struts application development much easier for developers. The easy–touse code wizards in JBuilder can create the Struts infrastructure efficiently and eliminate lot of
hand coding. With the help of JBuilder, the developers now can focus on the business aspect of
their application, rather than framework development and configuration.
While JBuilder is capable of creating very complex Struts applications, let’s create a simple login
application (with Struts implementation) to understand the basic guidelines.
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Create a New Project in JBuilder 8 and name the project as StrutsProject in the directory
E:/DEMO/WebSphere/StrutsProject.
Make WebSphere Application Server Advanced Edition 4.0 as the target server for this project.
Click Project -> Project Properties -> Server tab and make sure that WebSphere Application
Server Advanced Edition 4.0 is selected from the combo box.
Create a Web application and enter the Web application Name and Directory as LoginApp. Select
Struts 1.0 under JSP/Servlet Framework of Web Application Wizard. Click OK.
Expand the Web application LoginApp in JBuilder project tree . Note that struts-config.xml is
already created for this struts application.
Figure 14 shows the JBuilder Web Application Wizard, which allows the user to choose Struts 1.0.

Note: JBuilder 8 does not officially support the beta release of Struts 1.1. However, if you enable your
struts-config.xml file for Struts 1.1 and download the Struts 1.1 .jar file to the <jbuilder>/extras folder, you
will see support for Struts 1.1. The Struts Config Editor will display elements and attributes specific to 1.1.
Additionally, if your Struts Web application uses a tiles.xml file for presentation, a visual editor for the Tiles
configuration file is available.
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Figure 14: JBuilder provides wizards to create a Struts Web application
Create two JSPs (login.jsp and message.jsp) using JBuilder JavaServer Pages wizard. Note that
JSP Wizard—Step 2 of 4 allows users to select struts taglibs. See Figure 15 for details.
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Figure 15: JSP wizard allows users to select the Struts taglibs
For this exercise, don’t select any tag libraries. Click Finish at JSP Wizard. Edit login.jsp and
message.jsp in JBuilder editor and copy the following code.
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login.jsp
<html>
<head>
<title>Login Page</title>
</head>
<body>
Please enter your user name and password
<br>
<form action="loginAction.do" method=POST>
<table>
<tr>
<td>User Name:</td>
<td><input type=text name=userName>
</tr>
<tr>
<td>Password:</td>
<td><input type=password name=password>
</tr>
<tr>
<td colspan=2 align=right><input type=submit value="Login"></td>
</tr>
</table>
</form>
</body>
</html>

Table 2: login.jsp : the primary JSP for this Struts application
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message.jsp
<html>
<head>
<title>
message
</title>
</head>
<body bgcolor="#ffffff">
<h1>
Login Successful
</h1>
</body>
</html>

Table 3: message.jsp : this JSP activates after a successful login

Note: login.jsp is the primary JSP for this application. It accepts userName and password. message.jsp
displays a message to the users after successful login. login.jsp and message.jsp represent the VIEW
layer in this Model 2 struts application.

Create a Struts Action using the wizard from JBuilder Object Gallery. From Object Gallery, select
Web tab, click Action and click OK.
In Action Wizard–Step 1 of 2, enter the package name as com.borland.demo.web and Action as
LoginAction. See Figure 16 for details.
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Figure 16 : JBuilder Action Wizard to create a Struts Action
In Action Wizard–Step 2 of 2, click the ellipses against Input JSP and select login.jsp form the
pop-up window. Click Finish. See Figure 17 for details.
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Figure 17: JBuilder Action Wizard allows the user to select the JSP for which the Struts Action has
to be created
The above wizard creates a file called LoginAction.java. Find the file from JBuilder project tree
and edit it as shown in Table 4.
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LoginAction.java
package borland.demo.struts;
import org.apache.struts.action.*;
import javax.servlet.http.*;
import javax.servlet.RequestDispatcher;
import java.io.IOException;
import javax.servlet.ServletException;
public class LoginAction extends Action {
public ActionForward perform(ActionMapping actionMapping,
ActionForm actionForm, HttpServletRequest httpServletRequest,
HttpServletResponse httpServletResponse) throws IOException,
ServletException {
String userName = httpServletRequest.getParameter("userName");
String password = httpServletRequest.getParameter("password");
System.out.println("Username provided =" + userName);
System.out.println("Password provided =" + password);
if (userName!=null && password!=null &&
userName.equals("suds") && password.equals("borland")) {
return new ActionForward("/message.jsp");
}
else {
return new ActionForward("/login.jsp");
}
return null;
}
}

Table 4: LoginAction.java: implementation of action

Note: The LoginAction.java file implements the action that is defined in the login.jsp. Note the following
line from login.jsp.
<form action="loginAction.do" method=POST>
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The LoginAction gets the userName and password parameters, checks the authentication, and then
forwards the action to message.jsp ( upon successful login ) or login.jsp (upon unsuccessful login ).
For simplicity, the authentication for userName is suds and password is borland.
The <action-mapping> is available in the struts-config.xml file. Take a look at this file. It
demonstrates how the loginAction.do in the login.jsp is mapped to the LoginAction class. The .do
is a conventional representation of the URI. Open the web.xml and check for the servlet-mapping
for servlet-name action. The url-pattern for action is *.do. Also action is nothing but an instance of
the Controller Servlet org.apache.struts.action.ActionServlet.

struts-config.xml
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE struts-config PUBLIC "-//Apache Software Foundation//DTD
Struts Configuration 1.0//EN"
"http://jakarta.apache.org/struts/dtds/struts-config_1_0.dtd">
<struts-config>
<action-mappings>
<action type="borland.demo.struts.LoginAction" input="/login.jsp"
path="/loginAction" />
</action-mappings>
</struts-config>

Table 5: struts-config.xml

Deploy and run the Struts application
Create an EAR. To create an EAR in JBuilder, click File -> New -> Enterprise tab of Object
Gallery -> click EAR -> click OK. Leave the defaults in all the steps except in EAR Wizard—
Step 5 of 6. Make sure to check the checkbox under Include in EAR Wizard–Step 5 of 6. This
includes the Web module LoginApp to the EAR.
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Note: You can always include additional Web and EJB modules to EAR at the later stage. Right-click the
.eargrp from JBuilder project tree and click Properties. Click Web tab. JBuilder automatically identifies the
available Web modules and provides an option to the users whether or not they want to include it.

Make the EAR. Start WebSphere in JBuilder and deploy the ear into WebSphere. To get help on
how to start WebSphere and deploy modules into WebSphere, refer to the chapter Working with
JSPs.
Now run the project (click F9 or click the Run Project icon, then login). WebSphere AE
http:9080 should start within JBuilder. Also you should see the running login.jsp in the Borland
AppBrowser.™
See Figure 18 for details.

Figure 18: JBuilder running Struts application using WebSphere Application Server AE 4.0
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Enter the User Name as suds and Password as borland. You should see the Login Successful
message. Try entering some other information, and it should bring the normal login.jsp screen again
for re-entry of User Name and Password.

Optimizing Web applications
JBuilder 8 Enterprises has out-of-the-box integration with Borland Optimizeit Suite.
Optimizeit Suite is a separate product available for purchase or as a trial download from the
Borland Web site. Please visit the following link for downloading the latest version (version 5) of
Optimizeit Suite. http://www.borland.com/products/downloads/download_optimizeit.html
Optimizeit Suite includes three different tools: Optimizeit™ Code Coverage, Optimizeit™ Profiler,
and Optimizeit™ Thread Debugger. For more information, visit
http://www.borland.com/optimizeit/index.html
Code Coverage
Optimizeit Code Coverage enables developers to view the execution frequency of each class,
method, and line of code, and to reduce application footprint by removing dead code.
Profiler
Optimizeit Profiler enables developers to maximize application speed and reliability and to quickly
isolate critical code that requires performance improvements.
Thread Debugger
Optimizeit Thread Debugger helps developers to solve mysterious thread issues more easily, get the
status of all threads and monitors in real time, avoid thread starvation and contentions that lead to
crashes, and predict deadlocks before they occur.

Note: During Optimizeit Suite installation, the installer automatically detects JBuilder installation from the
user’s machine and prompts for integrating with JBuilder. If the user says OK, then both JBuilder and
Optimizeit are configured for tight integration.
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Optimizeit Suite reads the JVMs and helps the developers in profiling, thread optimizing, and code
covering their applications. If the JVM runs a Java application, Optimizeit can attach to the
application and display the memory, thread, and other information in a user-friendly way, which
helps the developers to optimize their applications.
Optimizeit Suite is a very flexible tool, and it can attach with various market-leading IDEs and
application servers. Visit the link http://info.borland.com/techpubs/optimizeit/ to find the supported
J2EE™ application servers, documentation, and other information about Optimizeit Suite 5.
For this case, let’s attach Optimizeit Suite with WebSphere Application Server 7.x.
Click the Optimize icon from JBuilder main menubar and click TestJSP. The Runtime
Configuration window pops up and allows users to select one of the three tools (Profiler, Thread
Debugger, Code Coverage). Select Profiler from the combo box and click OK.
See Figure 19 for details.
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Figure 19: Runtime configuration window to choose which Optimizeit Suite tool to use
Click OK and WebSphere AE 4.0 Http 9080 starts within JBuilder 8. Note that Optimizeit
Profiler is attached to WebSphere and profiling the real-time JVM information. To run your
TestJSP, right-click the JSP from JBuilder project tree, click WebRun, click TestJSP.
See Figure 20 for details.

Figure 20: Optimizeit Profiler attached to WebSphere Application Server AE 4.0 within JBuilder 8
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To go to the normal WebSphere output window, click the Console output, input and errors icon
on the left. Also you can click Show Virtual Machine information and Show CPU profiler for
different operations.
The Profiler shows information about all the classes available in the JVM. If you would rather like
to see the information about your application only, type com.borland.demo.web.Test* at the
Filters text area. This will show you the packages started with “borland” only.
To attach Thread Debugger with WebSphere, from JBuilder main menubar, click Run ->
Configurations -> select TestJSP -> Edit -> click Optimize -> Select Thread Debugger from the
Type combo box.
See Figure 21 for Thread Debugger starting in JBuilder and attaching WebSphere.

Figure 21: Optimizeit Thread Debugger started in JBuilder 8 and attached with WebSphere
Application Server AE 4.0
Optimizeit Code Coverage can be started in the similar way.
There are many features available in Optimizeit Suite that help to detect critical memory leaks,
performance issues, deadlocks, etc. This white paper just explained a snapshot of some of the
features of Optimizeit Suite. Please read the Optimizeit Suite product documentation for
information about other features.
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Troubleshooting
Note: The troubleshooting tips provided here are simple workarounds to understand and fix the JBuilderWebSphere integration challenges. Borland is not responsible for supporting WebSphere related
issues/fixes. Please contact WebSphere support team for other support-related questions/issues about
WebSphere Application Server.

Useful Links
Refer to the following link for a list of bugs that is fixed in WebSphere Application Server 4.0.3
http://www-1.ibm.com/support/manager.wss?rs=180&rt=0&org=SW&doc=1052938
Refer to the following link for information and troubleshooting tips for WebSphere Application Server
Advanced Edition. http://www3.ibm.com/software/webservers/appserv/doc/v40/ae/infocenter/index.html
Refer to the following link for a PDF file helping with identification of problems and providing solutions.
http://www-3.ibm.com/software/webservers/appserv/doc/v40/ae/infocenter/was/pdf/nav_PDguide.pdf

Error 1: Optimizeit™ Profiler doesn’t start
Error description

Figure 22: Error Message while staring Optimizeit Suite tools in JBuilder
When did this happen
I am trying to start Optimizeit Profiler by clicking Optimize Project icon from JBuilder toolbar.
When I click TestServlet or TestJSP configurations, I get the above error.
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Cause
This is a known issue with JDK, and Borland is working to find a solution soon.
Workaround
In Windows, navigate to <user_home>\.jbuilder8 e.g., C:\Documents and
Settings\<user_name>\.jbuilder8) and open a file called user.properties. Scan the file to find the
lines similar as below. Replace them with the following lines. Make sure to change the installation
directory of WebSphere appropriately. Also, keep a backup before making any changes.
optimizeit;jdkCache0.3=E:\\IBM\\WebSphere\\AppServer\\java\\bin\\javaw;3;130;1;0
optimizeit;jdkCache1.2=E:\\IBM\\WebSphere\\AppServer\\java\\bin\\javaw;3;130;1;0
optimizeit;jdkCache2.2=E:\\IBM\\WebSphere\\AppServer\\java\\bin\\javaw;3;130;1;0
A patch for this issue will be released soon in http://codecentral.borland.com

Error 2: WebSphere doesn’t start
Error description
JORB0086: Port 9000 is in use. Specify a different port number.
When did this happen
I am trying to start WebSphere within JBuilder and getting the above error in the WebSphere AE
4.0 http:9080 tab.
Cause
This is because WebSphere uses port 9000 for administrative purposes, and it is used by some other
processes as well. If you have killed the running WebSphere already, then there may be WebSphere
Java processes running in Task Manager.
Solution
Try to find which process is using the port 9000, stop that process, and start WebSphere in JBuilder
again. If you can’t stop that process, then change WebSphere administrative port number to
something else.
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Open Task Manager and stop the running Java processes, and restart WebSphere in JBuilder.

Error 3: Deployment of EAR to WebSphere failed
Error description
java.rmi.ServerException: RemoteException occurred in server thread; nested
exception is:
java.rmi.ServerException: RemoteException occurred in server thread; nested
exception is:
java.rmi.RemoteException: ; nested exception is:
java.rmi.RemoteException: ; nested exception is:
com.ibm.etools.archive.exception.DeploymentDescriptorLoadException:
META-INF/application.xml

When did this happen
I have created an EAR module successfully, started the WebSphere within JBuilder, and am trying
to deploy the EAR into WebSphere. I am getting the following error in WebSphere Application
Server Advanced Edition 4.0 Enterprise Deployer.
Cause
Seems like the EAR files don’t have the Web module. Probably you have missed the step to include
the Web module in the EAR file.
Solution
Check the WebSphere AE 4.0 http:9080 tab to analyze the error message. Check if your error
message is something similar to the following Table 6.

Error Message in WebSphere AE 4.0 http:9080
1ce9945d ExceptionUtil X CNTR0020E: Non-application exception occurred while
processing method getRemoteArchiveInfo on bean
BeanId(admin#repository.jar#FileBrowserService, f1c72ee9f0):
java.rmi.ServerException: RemoteException occurred in server thread;
nested exception is:
java.rmi.RemoteException: ; nested exception is:
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java.rmi.RemoteException: ; nested exception is:
com.ibm.etools.archive.exception.DeploymentDescriptorLoadException: METAINF/application.xml
java.rmi.RemoteException: ; nested exception is:
java.rmi.RemoteException: ; nested exception is:
com.ibm.etools.archive.exception.DeploymentDescriptorLoadException: METAINF/application.xml
java.rmi.RemoteException: ; nested exception is:
com.ibm.etools.archive.exception.DeploymentDescriptorLoadException: METAINF/application.xml
com.ibm.etools.archive.exception.DeploymentDescriptorLoadException: METAINF/application.xml
Stack trace of nested exception:
com.ibm.etools.archive.exception.ResourceLoadException: Could not load
resource: META-INF/application.xml in archive
E:/DEMO/WebSphere/StrutsProject/StrutsProject.ear
Stack trace of nested exception:
com.ibm.etools.archive.exception.ArchiveRuntimeException: An Exception
occurred while parsing xml:Line #: 5:Column #: 16
Stack trace of nested exception:
org.xml.sax.SAXParseException: The content of element type "application" is
incomplete, it must match "(icon?,displayname,description?,module+,security-role*)".

Table 6: Error Message in WebSphere AE 4.0 http:9080
Solution
From the JBuilder project tree, right-click the eargroup .eargrp and click Properties. See Figure
23 for details.

Figure 23: EARGRP Properties

40

Web Development Using JBuilder® 8 and WebSphere® Application Server

Click on the Web tab of the Properties window and make sure that the checkbox under Include is
checked.

Error 4: Invalidate the Web Server plugin configuration file
Error description
1ce9945d ModuleBean A ADMR2301I: Web Server Plugin Config. The administrative action
just performed may invalidate the Web Server plugin configuration file. Use the Plugin regen
operation of the Node to update this file.
When did this happen
I have started WebSphere Application Server AE 4.0 successfully in JBuilder and deployed the
EAR module. I see the above error in the WebSphere AE 4.0 http:9080 tab of the JBuilder
message pane.
Solution
This is not an error and rather a warning/information message that appears after every deployment.
It is safe to regenerate the plugins when this message appears. Open WebSphere 4.0 AE
Administrative Console, find the server-node, right-click server-node and click Regen WebSphere
Plugin. See Figure 23 for details.

Figure 24: WebSphere Administrative Console: Plugin regen operation

41

Web Development Using JBuilder® 8 and WebSphere® Application Server

Conclusion
JBuilder is a highly productive environment for Java development, deployment, testing, and
optimization. Developers can increase their productivity and reduce the project lifecycle by using
JBuilder as a Java application lifecycle management environment. This white paper is focused only
on JSP, servlets, and Struts applications. JBuilder has many other features that make Web
development a smooth experience for the developer. If you have JBuilder installed, try the tutorials
available in JBuilder Help. Also refer to other white papers available in the Borland Web site for
EJB and Web Services development.

Additional infor mation
JBuilder Online documentation
http://info.borland.com/techpubs/jbuilder/jbuilder8/index1280x1024-ent.html
OptimizeIt Online documentation
http://info.borland.com/techpubs/optimizeit/optimizeit5/index1280x1024.html
Borland JDataStore™
http://www.borland.com/jdatastore/index.html
Link to other JBuilder 8 white papers
http://www.borland.com/jbuilder/white_papers/
Borland® Enterprise Server, AppServer™ Edition
http://www.borland.com/besappserver/index.html
Sun® Microsystems Java 2 Platform Enterprise Edition
http://java.sun.com/j2ee/
JBuilder OpenTools
http://www.borland.com/jbuilder/resources/jbopentools.html
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Feedback and suggestions
Please send your feedback and suggestions to
Sudhansu Pati, Systems Engineer
spati@borland.com
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