FAQ: Upgrade pricing eligibility for Delphi, C++Builder and RAD Studio 2010

By: Tim DelChiaro

Abstract: Updated Feb 4, 2010 to reflect the latest qualifications for upgrade pricing

FREQUENTLY ASKED QUESTIONS

Effective February 1, 2010, only users of 2006-2009 versions of Delphi, C++Builder, Borland Developer Studio and RAD Studio are eligible for upgrade pricing on RAD Studio 2010, Delphi 2010 and C++Builder 2010 upgrades. Academic licenses do not qualify for upgrade pricing.

When Embarcadero announced the 2010 versions, the published upgrade rules were that users of 2006-2009 versions were eligible for upgrade pricing and that upgrade pricing was also being extended to owners of 2005 and earlier versions for a limited time. That limited time ended January 31, 2010.

Beginning February 1, 2010, only registered users of versions 2006 through 2009 are eligible for upgrade pricing to version 2010. Users of any older version have to pay the New User price to get version 2010.

Upgrade Requirements and Return Policy

  • Customers purchasing an upgrade must have a qualifying older version of a product registered to their user account
  • Our product licensing mechanism will enforce this policy by verifying registration following purchase and will only activate purchased products for purchases that meet the Qualifying Purchase criteria.
  • If you don’t have a previously registered qualifying product, you will not be able to register and use the upgrade.
  • No returns or refunds will be accepted except where required by law. Customers are expected to review their eligibility before purchase

Q: If I own a 2005 or older product are you saying that I will now no longer be able to move my projects to version 2010 or future versions?
A: You will still be able to move your existing Delphi projects to the latest version. The only thing that has changed is you won’t be able to purchase the version 2010 product at a discounted upgrade price. You will need to pay the “new user” price.

Q: Can I still get upgrade pricing if I am a registered user of a version 2006, 2007 or 2009 product?
A: Yes. Registered users of versions 2006-2009 still qualify for upgrade pricing to the 2010 products.

Q: What if I own an older version (2005 or earlier) and still try to purchase an upgrade product after February 1st, 2010? Will it still just work?
A: No. You won’t be able to register the upgrade and the product will only function as a 30-day trial.

Q: Do I need to have the older version installed on the same computer?
A: No. The checking for ownership is done based on your registration of the earlier 2006-2009 product. You must register the new version with the same Embarcadero Developer Network (EDN) account (formerly Borland Developer Network or CodeGear Developer Network) user name and password that you used to register your earlier qualifying product.

Q: What if I forgot my user name and password from the older registration or don't remember which older versions I registered?
A: Just go to https://members.embarcadero.com to have your password re-sent to you if you’ve forgotten it, and to look up your previously registered software if necessary.

Q: Can I still upgrade from version 2005 or earlier to versions 2007 or 2009 after February 1st, 2010?
A: Yes. However, users generally want the latest version with the latest capabilities (like Windows 7, touch development, the C++ Class Explorer, and latest database drivers) rather than upgrading to an outdated earlier version.

Q: What is the exact list of qualifying products for the upgrades?

Qualifying products for all 2010 Architect upgrades

Any Architect or Enterprise edition of:

  • Delphi 2006-2009
  • C++Builder 2006-2009
  • Delphi and C++Builder Bundle 2009
  • Borland Developer Studio 2006
  • CodeGear RAD Studio 2007-2009

Qualifying products for all 2010 Enterprise upgrades

Any Enterprise or Professional edition of:

  • Delphi 2006-2009
  • C++Builder 2006-2009
  • Delphi and C++Builder Bundle 2009
  • Borland Developer Studio 2006
  • CodeGear RAD Studio 2007-2009

Qualifying products for all 2010 Professional upgrades

Any Professional edition of:

  • Delphi 2006-2009
  • C++Builder 2006-2009
  • Delphi and C++Builder Bundle 2009
  • Borland Developer Studio 2006
  • CodeGear RAD Studio 2007-2009
  • Turbo Delphi 2006 Professional
  • Turbo C++ 2006 Professional

Q: What if I need to try out the new version before I upgrade?
A: You can download a free trial of Delphi, C++Builder or RAD Studio from their respective trial download page.

Q: Why should I upgrade to RAD Studio rather than to just Delphi or C++Builder?
A: With RAD Studio you get the flexibility to build applications with Delphi using the Delphi language; the same rapid development advantages of Delphi plus the C++ language and libraries in C++Builder; and the ability to create .NET apps with Delphi Prism; all for a great price.

Q: What if I want even more beyond RAD Studio? Do you have anything like MSDN?
A: Yes. Embarcadero All-Access.

With Embarcadero All-Access you get a complete set of world-class application development and database tools.

All-Access Developer Tools include:

  • Delphi (for Windows)
  • C++Builder (for Windows)
  • Delphi Prism (for .NET)
  • JBuilder (for Java)
  • J Optimizer (Java performance)
  • Delphi for PHP
  • 3rdRail (Ruby on Rails)

All-Access Database Tools and Databases include:

  • Rapid SQL (development)
  • ER/Studio (modeling)
  • Change Manager
  • DBArtisan (administration)
  • DB Optimizer (performance)
  • InterBase SMP (database)

Learn more about Embarcadero All-Access or Download a free trial of All-Access.

Q: How can I purchase an upgrade?
A: You can purchase an upgrade from the Embarcadero Online Store, find an Embarcadero Partner in your region, or contact your Embarcadero representative for volume licensing.

Q: Where can I find more information on migrating applications to version 2010?
A: Visit the Embarcadero RAD Studio Migration and Upgrade Center at http://www.embarcadero.com/rad-in-action/migration-upgrade-center for information on upgrading Delphi, C++Builder and Delphi Prism applications.

Q: Where are your upgrade requirements and return policy stated?
A: At http://www.embarcadero.com/upgrade-requirements-and-return-policy.

Server Response from: ETNASC03