Sygate Personal Firewall PRO 4.2 causes InterClient error

By: Quinn Wildman

Abstract: InterClient returns the error

Installed versions of InterClient and InterServer use incompatible client/server protocol versions.

InterClient is InterBase's JDBC class 3 driver which allows Java applications to connect to InterBase.

InterServer is an applications which runs on the same machine as InterBase. InterClient connects to InterServer, which then connects InterBase.

When the version of InterServer and InterBase are different, this results in the error:

Installed versions of InterClient and InterServer use incompatible client/server protocol versions.

Based on customer input it has been reported that if Sygate Firewall Pro version 4.2 is installed on the same machine as InterServer/InterClient this problem will occur. This problem is reported to fixed in Sygate Firewall version 5

Server Response from: ETNASC04