"Can't load library libncurses.so.4: can't open file" When starting InterBase on Red Hat

By: Gabe Goldfield

Abstract: The error is due to Redhat 7.0, 7.1, or 7.2 not having this library

Problem: Starting InterBase on Redhat 7.x Linux and received the error message: "Can't load library libncurses.so.4: can't open file".

Solution: The error is due to Redhat 7.x not having this library. The library libncurses.so.4 is specific to RedHat version 5.x.

The workaround is to create a symbolic link libncurses.so.5 to libncurses.so.4. on Redhat 7.x. The libraries are located in the: /usr/lib directory. For Red Hat 7.0 the syntax is: ln -s libncurses.so.5.0 libncurses.so.4

For Red Hat 7.1 the syntax is: ln -s libncurses.so.5.1 libncurses.so.4

For Red Hat 7.2 the syntax is: ln -s libncurses.so.5.2 libncurses.so.4

Server Response from: ETNASC03